Platform Availability
Resolved
Oct 29 at 10:28pm UTC
All services have been restored following the global Microsoft Azure outage.
Affected services
Updated
Oct 29 at 10:13pm UTC
Traffic is being restored slowly to all regions. Services should be available but there may be intermittent connectivity issues for a while still. Retrying a failed request may result in a successful completion.
Affected services
Updated
Oct 29 at 08:30pm UTC
Microsoft is continuing to work on the global issue affecting Azure Front Door.
Microsoft: We initiated the deployment of our ‘last known good’ configuration, which has now successfully been completed. Customers may have begun to see initial signs of recovery. We are currently recovering nodes and routing traffic through healthy nodes, and as we make progress in this workstream, customers will continue to see improvement.
Customer configuration changes will remain temporarily blocked while we continue mitigation efforts. We will notify customers once this block has been lifted.
Some customers may also have experienced issues accessing the Azure management portal. We have failed the portal away from AFD to mitigate these access issues. Customers should now be able to access the Azure portal directly, and while most portal extensions are functioning as expected, a small number of endpoints (e.g., Marketplace) may still experience intermittent loading problems.
At this stage, we anticipate full mitigation within the next four hours as we continue to recover nodes. This means we expect recovery to happen by 23:20 UTC on 29 October 2025.
You can view the current status of the issue here: https://azure.status.microsoft/en-us/status.
Affected services
Created
Oct 29 at 04:00pm UTC
PayQuicker is working with Microsoft on a connectivity issue affecting the PayQuicker platform.
Affected services