Back to overview
Degraded

Difficulty Accessing Account

May 21 at 02:31pm UTC
Affected services
API
Account Holder Website
Management Website

Resolved
May 21 at 03:00pm UTC

The issue has been resolved and all services are once again available.

Created
May 21 at 02:31pm UTC

Starting at 10:27AM ET, some users may experience errors when accessing their account online or utilizing API services. The issue is intermittent and retrying the operation may be successful. The root causal has been identified as a traffic routing issue with one of our cloud hosting partners (Microsoft Azure). We are engaged with the partner and are working towards a resolution. Updates will be provided as they are available.