Possible Bank Transfer Issues
Resolved
May 15 at 08:01pm UTC
A small percentage of users may experience an issue when attempting to perform a bank transfer or add a new external bank account to their account outside of the US. The issue has been identified at one of our partners and they are actively working on a resolution. If you attempt to perform a bank transfer during this time, your external bank account may be automatically disabled in your account. When the issue has been resolved, any affected external bank accounts will be re-enabled without any action required.
If you were attempting to perform a bank transfer during this time and were impacted by the issue, you will be able to retry your bank transfer once the issue has been resolved.
Updates will be provided as they are available.
Affected services